WEB-O-RAMA VERSION HISTORY

Notes

Please Help Keep Web-O-Rama Free!

If users in a financial position to do so would consider making modest donations to help with programming costs, I can continue to offer Web-O-Rama as donationware rather than traditional shareware (timed, or limited to a certain number of uses without a registration key). Programming takes both time and money, neither of which I seem to have enough of these days. If you find the program useful, please consider making a small donation. I would be grateful. My mailing address is Kevin Gunn, P.O. Box 442155, Lawrence  KS  66044-8933. 
Any amo
unt cheerfully accepted.
 
International money orders are more than welcome from overseas users.


Web-O-Rama Now Available on Floppy Disks or CD

If you’d like a copy of the latest version of Web-O-Rama on floppy disks or CD, write to me at Kevin Gunn, P.O. Box 442155, Lawrence  KS  66044-8933, or e-mail me (kgunn@cjnetworks.com or kegunn@delphi.com) for details. The price [
September
 1998] is $9.95 for floppies and $12.95 for a CD, which includes the cost of materials, postage, and handling. Checks and money orders (including international money orders) accepted

Updates

Please check my site at http://people.delphi.com/krgunn/index.html, for product updates. Download the latest beta version before reporting bugs.

Summary of Changes Since V. 5.03


Interface improvements to all the dialogs.



I installed Visual Basic 6 on August 29. VB6 improves the function of many of the controls
, 
including 
the 
Rich Text Box, which 
comprises
 the main editing window
.
 
The Rich Text Box now prints
 
“normally
.
”
 
VB6 also compiles the code more efficiently, resulting in a smaller .exe file.


You can now save custom colors using the Hex Value dialog.


A Style Sheet 
dialog added. Although its operation is reasonably intuitive, a
n
 understanding of style sheets is necessary
 in order to use it
.
 This dialog is still in 
development
.
 User input would be appreciated.


Major improvements to the Tag List dialog. A row of windows across the bottom displays the browsers and HTML version each tag 
and each attribute 
works with. Red indicates no support or partial support, green indicates full support.
 This information was painstakingly gathered from a variety of sources and represents the most recent available.


Added 
a 
Splash Screen
 (can be toggled off under the 
“Options
” menu)
 
that
 
appears when the program first starts.



If you click on 
“Date
” 
u
n
der
 the 
“Insert
” menu a dialog opens showing a calendar. A drop-down list gives you a number of options.


Major improvements to the interface
, including 
code enhancements that result in smaller resource use.
.


A new Open-file View toolbar added
. 
Clicking on i
t
 under the “View” menu opens a viewing window beneath 
and to the left of 
the toolbars
 that shows all currently open files on the first tab and drive
 
/
 
directory
 
/
 
files on the second tab. Clicking on a particular file name on the “Open Files” tab brings the file to the front. You can open files from the “Directories” tab. Can be toggled on and off.

Improvements to the dialogs. The Image dialog now has a drop-down list for “Alternate Text.” After selecting an image, this box will contain several “Alternate Text” options. I found that I liked having the image dimensions listed. If you don’t want to use one of the options from the list, you can type one of your own.


Summary of Changes Since V. 4.70

“Unformat Text” option added under “Text” menu. If you’re cutting and pasting from a Word document or other document that contains formatting for typeface, type size, etc., “Unformat Text” will remove the formatting.

All of the option buttons replaced with “graphical style” push buttons. 

“Spinner” controls added beside all the fill-in boxes that require numbers. I’ve been putting off doing this because it requires an additional .ocx and has entailed the release of a new full version in order to install the .ocx on users’ systems. It significantly enhances the program, however, and I felt it was worth it.

You can now copy image and sound files from other places on your hard drive to the directory you’re working in without having to exit Web-O-Rama. On the Body, Image, and Sound dialogs, there’s an “Autosave” checkbox. Check it to have images and sounds saved to the selected directory. “Autosave” will not overwrite a file of the same name (you’ll have to do this manually).

Option added (or “re-added,” under the “Options” menu) to have cursor “Always Between Inserted Tags” or “At End of Inserted Tags if Text Selected.” The purpose of this feature may not be immediately self-evident, but it’s something I personally use. The first option is the default. The second option is particularly useful if you’re inserting tags for the first time into a text file rather than creating an HTML file from scratch. 

New “flat” toolbar style (optional) and several redrawn graphics. I’m very fond of it.

The option to “Color Tags as You Work” has been removed for now. It wasn’t a very “smart” feature and it was easy for it to get stuck on the tag color. This has saved some space and has increased the program’s speed. There are some bugs in Visual Basic 5 that make a more efficient routine impossible (or at least painful). I’m hoping the bugs are fixed in Visual Basic 6, which is due out at the beginning of September, 1998. Look for Web-O-Rama 6._ about mid-September.

All screen fonts available on your computer are now “gathered” by Web-O-Rama when you start the program. Although the program may appear sluggish when loading (it takes about as long as it does when you use the normal Windows Font dialog . . . slower on some computers than others, depending on the number of fonts you have), you will be able to access the fonts from the various dialogs without “going out” to the Windows Font dialog. Selecting fonts (from the drop-down lists) is significantly faster from the dialogs! The font of the drop-down lists changes to the selected font. Don’t freak if you select a symbol font and you can no longer read anything on the menu . . . just hit your “up arrow” or “down arrow” key to move to the next or previous font. The font changes only where there is no “font sample” box on the dialog.

Several of the dialogs now have an option to “Include Relative Path to Image from Selected Directory” (drop-down list). If your images or sound files are in a subdirectory of your main HTML directory, selecting the main directory path will allow the images to display and the sounds to play when using “View in Browser.” If your subdirectory structure reflects the structure of your Web site, no path corrections will be necessary before uploading Web pages. This feature becomes more clear with use. If all your images and sounds are in the same directory as your HTML pages, however, it won’t appear to do anything (paths are unnecessary in this situation).

Several additional tags added to “Insert” menu, including such tags as <PRE> and <BLOCKQUOTE>.

Many many enhancements to the dialogs.

Support for up to six user-defined browsers (suggestion from a designer . . . I didn’t realize anyone had more than two or three). When searching for browsers other than Internet Explorer or Netscape, remember to change the “type of file” drop-down at the bottom of the Windows Find dialog to “All files (*.*)” or you will be unable to see the .exe files! I have been fooled by this myself.

Eight items now on the “Recent Files” list.

Summary of Changes Since V. 4.40

New image viewer on Image dialog, with scroll bars so you can see all parts of large images.

Long “Options” menu broken into three: “Tags,” containing the tag coloring options, “Text,” containing the text options, and “Options,” containing the program options.

Bug fixed that may have caused program error if accessing deleted or renamed files or directories.

Summary of Changes Since V. 4.00

Selected text can be made uppercase or lowercase (under “Options” menu).

Status bar added with line count/total number of lines, total number of open files, caps lock, num lock, and insert on/off.

An enhancement to the Character dialog allows you to replace many keyboard characters with HTML character codes.

Find and Find and Replace have been rewritten to be more functional and consistent.  “Close All” added to “Edit” menu.

A “Directories” menu shows the 8 most recently used directories and will open them (this has turned out to be an extremely convenient feature).

A lot of improvements to the code, including better error-handling.

When you “Save All” open files, the program returns you to file you were working on.

It is now no longer possible to open more than one instance of a particular file.

A button has been added for the alternate browser.

Summary of Changes Since V. 3.46

Fully NT-compatible.

Multiple files can be selected, opened, and saved (“Save All” added to “Edit” menu).

Replace dialog rewritten to include “Match Whole Word”; multiple-file search and replace, including Undo.

All dialogs now “remember” their last position.

Data can be imported and exported between dialogs.

Template dialog added.

Tags can be converted to upper- or lowercase.

Hex Value dialog rewritten to include multiple color palettes (16 colors and “Web-safe” colors).

Service Pack 3 fixed bug that prevented tags from coloring in files >32 kb.

Additional user options.

Skipped Version Numbers Indicate Minor Changes


3.46 (full version)

Full release version.

3.47 (beta)

Major improvements to Character dialog.

3.48 (beta)

Added option to have cursor back up so that it appears inside tags when tags are added. This is under the “Options” menu item (“Cursor Inside Tags”).

3.50 (beta)

Major changes to Tables and Forms dialogs.

3.54 (beta)

All dialogs now “remember” their last position and open in the same place they were left.

3.58 (beta)

Removed option to use background images on dialogs to help streamline program (there were a number of reasons for this). Made it possible to export data from dialogs to Define User Buttons dialog. Code optimization. Miscellaneous improvements and enhancements. Added Create Template dialog. Data can be imported from various dialogs to create user-defined templates.

3.59 (beta)

Improvements to interface. Combined Define User Buttons and User Buttons dialogs for more intuitive operation. Additional enhancements.

3.60 (beta)

Revamped interface. Put “Make Tags Uppercase” and “Make Tags Lowercase” back in. The routine now leaves the material between quote marks alone (thanks to Don of GreenGecko Software, who out of the blue offered me his help).

3.61 (beta)

Additional improvements to Create Template. Many additional enhancements.

3.62 (beta)

Removed captions from dialog menu buttons. The images are reasonably self-explanatory, and if you pause the mouse pointer over any of the buttons a Tool Tip will pop up explaining the button function. This allows more screen area for editing. You can also change both the back color and fore color of the text editing window. Removed the About box. Unnecessary at this point and just adding to the size of the program.

3.64 (beta)

Added option to start program with no open text window and option to start text window maximized or normally.

3.66 (beta)

Misc. fixes. Added centered and right-justified paragraph buttons to standard toolbar.

3.68 (beta)

Reduced number of user-defined buttons to 18 from 24. Fixed an odd glitch with the Frames and Form dialogs.

3.70 (beta)

Major changes to Create Template dialog. Major internal code changes. Misc.  fixes and enhancements.

3.71 (full version)

Compiled after installation of SP3, which fixes numerous problems with the Rich Text Box and other Visual Basic bugs. Includes major changes to the Character dialog and internal code enhancements. Visual Basic programmers should read the note at the top of this file before installing.

3.89 (beta)

Enhancements and improvements. Making tags uppercase or lowercase now skips over material between <!-- and -->.

3.93 (beta)

Added support for non-dithered “Web-safe” colors. Major enhancements to Hex Value dialog. Code optimization.

3.95 (beta)

Further enhancements to Hex Value dialog.

3.99 (beta)

Multiple files can be selected and opened simultaneously; “Save All” added to “Edit” menu (will save all open files). “Save All” does not work if you have newly created files that haven’t been saved once.

3.991 (beta)

Fix to multiple file open and save.

3.993 (beta)

Experimental multiple-file search and replace, including undo. PLEASE back up files before using this new feature. Not thoroughly tested.

3.994 (beta)

Multiple-file search and replace less buggy. Additional improvements.

3.999 (beta)

This version is NT-compatible! Fixed bug that caused a crash when using “Replace” under some circumstances. Added “Whole Word” to search criteria for “Replace.” Added About dialog back in.

4.0 (full version)

Full non-beta version.

4.04 (beta)

Added “Close All” to “Edit” menu. Added “Directories” menu item that lists recently used directories. Fixed but that prevented “Save All” from appearing on “Edit” menu under some circumstances.

4.09 (beta)

Changes to “Directories” menu item, including removal of “Clear Directories” (see “Clear Recent Files,” below). Fixed bug that caused program error if Default Directory were set to a directory on a Zip drive and then the directory was renamed or deleted. Removed “Clear Recent Files” from “Options” menu. There are only four things on the Recent Files list and the code involved to delete them wasn’t worth the overhead.

4.12 (beta)

More internal improvements. Added “Clear Recent Files” and “Clear Directory List” back to the “Options” menu. I figured out a way to optimize the code.

4.14 (beta)

Fixed an odd problem. Opening a file wouldn’t change the directory the program was accessing, so trying to view a file in a browser wouldn’t always display images. This “error” crept into the betas after the release of v. 4.0.

4.16 (beta)

Find and Find and Replace have been rewritten. At present, you can no longer choose the search direction.

4.17 (beta)

Further improvements to Find and Find and Replace. They no longer “loop” from the end of the file back to the beginning. There is still no search direction option.

4.22 (beta)

Button added to toolbar for alternate browser. Program will no longer open multiple instances of the same file. Additional code improvements.

4.27 (beta)

Bugs (I hope) worked out of Find and Find and Replace. Keyboard characters can now be replaced with HTML character codes using the Character dialog.  Additional code improvements.

4.30 (beta)

Two instances of the same file can no longer be opened. Status bar added at bottom, showing line number/total lines, number of open files, caps lock, num lock, and insert status. Major improvements to the Character dialog replace feature. A major bug was eliminated. Previously, closing the program with one of the dialogs minimized rather than closed would generate an error. The “Undo Last” on the Find and Replace dialog has been disabled until I track down a problem with it.

4.31 (beta)

Problem with “Undo Last” has been fixed.

4.32 (beta)

Problem with “Undo Last” not fixed! The “Undo” buttons on the Find and Replace dialog have been removed. At present, there is no practical way to incorporate them while preserving the non-modal state of the dialog (a modal dialog requires that you complete your actions and close the dialog before being able to do anything to the text). “Tool Tips” added to many of the forms (this is in progress); moving the mouse cursor to a particular button will give you a brief description of the button’s purpose.

4.33 (beta)

More bugs fixed! “Make Selected Text Uppercase” and “Make Selected Text Lowercase” added under “Options” menu.

4.40 (full version)

More bugs fixed! “Make Selected Text Uppercase” and “Make Selected Text Lowercase” added.

4.42 (beta)

Fixed a bug that may have caused a program error if the Default Directory were set and the directory deleted or renamed, or may have caused program errors if trying to access deleted or renamed files. This always happens within 48 hours after a new full version is released!

4.44 (beta)

Automatic tag coloring as you type and an option to use colored tags when adding data from dialogs. Long “Options” menu broken into three: “Tags,” containing the tag coloring options, “Text,” containing the text options, and “Options,” containing the program options.

4.46 (beta)

Fixed bug causing program error when “Uncolor Tags” selected. Fixed “File Not Found” error (I think).

4.47 (beta)

Fixed yet another bug in the Replace dialog that could cause the last word replaced during a search (NOT a “Replace All”) to be duplicated. When using the “List” dialog, list items were being added in reverse order! Fixed in 4.47.

4.51 (beta)

New image viewer, with scrollbars, for Image dialog. Many additional enhancements!

4.54 (beta)

Fixed bugs in Image dialog (image viewer); additional enhancements.

4.56 (beta)

Many enhancements to the dialogs!

4.58 (beta)

“Use Subdirectory Path” checkbox added to Image dialog; additional enhancements.

4.59 (beta)

Fixes problem with spell checking; fixes problem with inserting files into other files; Image dialog rewritten; other bug fixes and enhancements.

4.66 (beta)

Removed Rules dialog to free up some space, removed option to use “Absolute Path” (pointless), added options to “Use Path to Subdirectory from HTML Directory” to Body, Image, and Sound dialogs, many improvements to dialogs, many internal enhancements.

4.67 (beta)

Fixed glitch with browser buttons.

4.68 (beta)

Enhancements to the List dialog. Additional enhancements.

4.70 (full version)

Additions to “Insert” menu. Additional enhancements.

4.72 (beta)

Improvements to “Add Path to Subdirectory from HTML Directory” feature. Image and sound files can now be copied from one directory to another from the Image and Sound dialogs.

4.75 (beta)

More improvements and interface enhancements. Body dialog redesigned. Web-O-Rama now supports up to six user-defined browsers.

4.78 (beta)

Improvements to interface. Improvements to Tag List dialog.

4.79 (beta)

Links dialog fixed so it is once again possible to add the link source “by hand.”

4.80 (beta)

Fixed some serious bugs associated with the Body, Image, Links, and Sound dialogs, which were generating errors. Hasty coding was to blame!

4.82 (beta)

Improvements to the Body, Image, Links, and Sound dialogs. Option buttons added so any of the text boxes can be used for the file data.

4.83 to 4.89 (betas)

Code enhancements.

4.90 (beta)

Made toolbar buttons flat and redesigned some of the button graphics. Code enhancements.

4.91 (beta)

Fixed slight problem with Image dialog image viewer. Code enhancements.

4.92 (beta)

Made raised toolbar buttons an option. Code enhancements.

4.94 (beta)

Two options for cursor position added under “Options” menu. Code enhancements.

4.95 (beta)

“List” button added to toolbar. Enhancements.

4.96 (beta)

Fixes several problems, including a bug in the Metaname dialog that could cause a crash. Other enhancements.

4.97 (beta)

There was a problem with the “Find Microsoft Word” menu item. It wasn’t enabling the spell checking feature of the “Edit” menu. It has been fixed. Files larger than 32 kb, however, can only be checked in sections.

4.99 (beta)

All screen fonts available on your computer are now “gathered” by Web-O-Rama when you start the program. Although the program may appear sluggish when loading, you will be able to access the fonts from the various dialogs without “going out” to the Windows Font dialog. Selecting fonts (from drop-down lists) is significantly faster from the dialogs now! Removed option to color tags as you work. The code was clunky and slow. I intend to add it back in if Visual Basic 6 fixes some problems.

5.0 (beta)

“Spinner” controls added beside all text boxes that require numbers. Many enhancements and refinements.

5.03 (full version)

More improvements.

5.05 (beta)

“Tree View” added. This shows a list of currently open files. Clicking on a file will bring it to the front. This feature can be toggled on and off from the “View” menu. Cool.

5.07 (beta)

A third toolbar added with Font Face, Font Size, and Font Color drop-down lists. I found that I frequently wanted to change fonts quickly. Highlight a section of text and make a selection. You can only select one of the font attributes at a time. Use the Font dialog for adding multiple attributes.

5.08 (beta)

Improvements.

5.09 (beta)

Improvements to some of the dialogs (Image dialog in particular). Code optimized.

5.11 (beta)

“Tree View” changed to “File View” (under the “View” menu) and is now the first tab on a left-aligned toolbar, providing a quick way to switch between open files. “Directories” is on the second tab and allows you to easily open files in the current, or any, directory. All toolbars can now be toggled on and off and their state will be “remembered.”

5.13 (beta)

Improvements and fixes.

5.14 (beta)

Added “Save Color” panel to Hex Value dialog.

5.16 (beta)

Improvements.

5.18 (final VB5 beta)

Improvements.

5.19 (unreleased beta)

Eliminated the Template dialog and added a Style Sheet dialog. Web-O-Rama has so many dialogs that Visual Basic sometimes locks up when I try to compile it. I had to remove something in order to add the Style Sheet dialog, and the Template dialog was the only one I could conscientiously remove. If you want templates, you can just create them as HTML files and save them.


Visual Basic 6 Installed


5.20 (
unreleased 
beta)

For some reason, no one liked the Font toolbar, so I removed it. Code optimized. Visual Basic 6 controls have some new and interesting features. I’m still experimenting.


5.24 (
unreleased 
beta)

All the toolbars (including the status bar, which is across the bottom) can be toggled on and off. Their state is remembered.

5.25 (
unreleased 
beta)

Major cosmetic improvements
 to the dialogs
. Additional miscellaneous code enhancements.


5.2
7
 (
unreleased 
beta)


Splash 
S
creen
 added (can be turned off under 
“Options
”). Improvements to Style Sheet dialog. It
’s still not terribly intuitive, but will help those familiar with style sheets to construct them. A few of the 
Style Sheet 
options are not completely functional
 yet
.
 Added a Date dialog (
“Date
” under the 
“Insert
” menu).



5.
30
 (
unreleased 
beta)


Tag List dialog comp
letely rewritten. All tags for which 
I
 
could find documentation are listed. Compatibility shown for both tags and attributes.



6.0 (full version)



Code cleaned up, miscellaneous enhancements and improvements.


6
.
0
2
 (
beta)


Two minor bugs fixed. Selecting an unavailable drive from the Directory View caused the program to crash. This has been fixed. Closing all open files, then opening File View and clicking on it would cause the program to crash. This has been fixed.





(



Kevin Gunn

P.O. Box 442155

Lawrence  KS  66044-8933



E-mail: kgunn@cjnetworks.com

Alternate e-mail: kegunn@delphi.com



Home page: http://people.delphi.com/krgunn/index.html





